A single or combination of Windows 2003 / 2008 Firewall and User Account Control (UAC) security measures can cause an item to fail when exporting or reviewing the item.
Display Errors:
Cannot retrieve item
Report this error to your system administrator
The EnterpriseVault.DirectoryConnection object reported an error. NULL
Or
Cannot retrieve item
Report this error to your system administrator
Failed to acquire file lock on C:\Users\vaultadmin\AppData\Local\Temp\EcmAPI\dOthSpruWCAIVz0BLJlsujJPWEI= in 30 seconds
Event Viewer:
Source: Accelerator Service Processor
Event ID: 375
Level: Error
Description:
APP AS - Customer ID: X - An Error has occured when retrieving Item SaveSetID: 201003118342142~201003112010350000~Z~E03E9F8EFC1902607151C5C3FF90C681 VaultID: 106672C9C60857B4F8C153FE234D898061110000EV64CA.ATEST.LOCAL Format: XML sAttachmentID: 0. System.Runtime.InteropServices.COMException (0x800706BA): The EnterpriseVault.DirectoryConnection object reported an error. NULL
Source: Accelerator Service Processor
Event ID: 375
Level: Error
Description:
APP AS - Customer ID: 2 - An Error has occured when retrieving Item SaveSetID: 201003128410652~201003121616530000~Z~A1364FB5D88C2C98AD583DCB59E7C1C1 VaultID: 106672C9C60857B4F8C153FE234D898061110000EV64CA.ATEST.LOCAL Format: XML sAttachmentID: 0. System.Runtime.InteropServices.COMException (0x80040308): Archive, Archive Folder, Vault Store or Retention Category does not exist at KVS.EnterpriseVault.Interop.IItem.Get(Int32 DetailLevel) at KVS.Common.VaultItem.Item.CallEcmAPI(String sSaveSetID, String sVaultID, String sAttachmentID, String sFormat)
Resolution:
Disable User Access Control and modify Windows Firewall on the Enterprise Vault Storage and Discovery Accelerator servers to allow Distributed COM ports communications between all EV servers
To disable UAC with Msconfig.exe:
1. Click Start, type msconfig, and then press Enter. The System Configuration tool opens.
2. Click the Tools tab.
3. Click Disable UAC and then click Launch. A command window appears, and shortly thereafter, a notification bubble appears informing you that UAC is disabled.
4. Restart the computer to apply the change.
To modify Windows Firewall:
DCOM requires port 135 for the initial session creation; after which any available port will be used to handle DCOM requests. In order to allow a firewall to remain in place and allow DCOM requests, the DCOM ports must be restricted to a defined set of port numbers and these additional ports be opened in the firewall. Microsoft recommends restricting a minimum of 100 DCOM ports. ( http://support.microsoft.com/kb/154596 ) Enterprise Vault recommends a minimum of 200 DCOM ports for the Enterprise Vault environment.
Creating the registry keys:
Use regedt32 in order to create the Reg_Multi_Sz string
Navigate to registry key: (the registry key may need to be created)
HKEY_LOCAL_MACHINE\Software\Microsoft\Rpc\Internet
Create the following three strings:
Ports
REG_MULTI_SZ
Value: (Example: 7001-7200)
PortsInternetAvailable
REG_SZ
Value: Y
UseInternetPorts
REG_SZ
Value: Y
To Automate opening of ports in the firewall:
Create a batch file using port 135 and the additional ports created in the registry keys
Format to use:
netsh firewall set portopening TCP 135 "DCOM Port 135"
netsh firewall set portopening TCP 7001 "DCOM Port 7001"
netsh firewall set portopening TCP 7002 "DCOM Port 7002"
netsh firewall set portopening TCP 7003 "DCOM Port 7003"
.
.
.
netsh firewall set portopening TCP 7198 "DCOM Port 7198"
netsh firewall set portopening TCP 7199 "DCOM Port 7199"
netsh firewall set portopening TCP 7200 "DCOM Port 7200"
Execute the batch file
To view firewall settings, open a Command Prompt and enter:
nettsh firewall show state verbose=enable