Type : Error
Event : 13360
Source : Enterprise Vault
Category : Storage Delete
Computer : EVServer.domain.local
Description:
An error was detected while accessing the Vault Database 'EVVSMailboxVaultStore_2' (Internal reference: {CADODataAccess::ExecuteSQLCommand} [.\ADODataAccess.cpp, lines {1317,1319,1338,1361}, built Nov 19 15:44:06 2014]):
Description:
The XML parse error 0xc00ce505 occurred on line number 1, near the XML text "
SQL Command:
usps_ExpiredSavesets
Additional Microsoft supplied information:
Source: Microsoft OLE DB Provider for SQL Server
Number: 0x80040e14
SQL State: 01000
Native Error: 00006601
HRESULT 0x80040e14
For more information, see Help and Support Center at http://telemetry.community.veritas.com/entt?product=ev&language=english&version=12.0.0.0&build=12.0.0.1528&error=V-437-13360
Type : Error
Event : 13360
Source : Enterprise Vault
Category : Storage Delete
Computer : EVServer.domain.local
Description:
An error was detected while accessing the Vault Database 'EVVSMailboxVaultStore_2' (Internal reference: {CADODataAccess::ExecuteSQLCommand} [.\ADODataAccess.cpp, lines {1317,1319,1338,1361}, built Nov 19 15:44:06 2014]):
Description:
The error description is 'A name contained an invalid character.'.
SQL Command:
usps_ExpiredSavesets
Additional Microsoft supplied information:
Source: Microsoft OLE DB Provider for SQL Server
Number: 0x80040e14
SQL State: 42000
Native Error: 00006602
HRESULT 0x80040e14
For more information, see Help and Support Center at http://telemetry.community.veritas.com/entt?product=ev&language=english&version=12.0.0.0&build=12.0.0.1528&error=V-437-13360
Type : Error
Event : 6796
Source : Enterprise Vault
Category : Storage Delete
Computer : EVServer.domain.local
Description:
A COM exception has been raised.
<0x80040e14>
Internal reference
{CVaultStoreDB::ScanExpiryItemsDoQuery} [.\VaultStoreDB.cpp, lines {1424,1432,1433,1435,1436,1437,1438,1439,1441,1443}, built Feb 22 12:33:38 2016]
An exception is raised when a process encounters an unexpected fault.
For more information, see Help and Support Center at http://telemetry.community.veritas.com/entt?product=ev&language=english&version=12.0.0.0&build=12.0.0.1528&error=V-437-6796
Type : Error
Event : 6796
Source : Enterprise Vault
Category : Storage Delete
Computer : EVServer.domain.local
Description:
A COM exception has been raised.
<0x80040e14>
Internal reference
{CVaultStoreDB::ScanExpiryItemsNext} [.\VaultStoreDB.cpp, lines {1456,1464}, built Feb 22 12:33:38 2016]
An exception is raised when a process encounters an unexpected fault.
For more information, see Help and Support Center at http://telemetry.community.veritas.com/entt?product=ev&language=english&version=12.0.0.0&build=12.0.0.1528&error=V-437-6796
Type : Error
Event : 6605
Source : Enterprise Vault
Category : Storage Delete
Computer : EVServer.domain.local
Description:
Failed to process all expired items in Vault.
<0x80040e14>
Vault Name: User 1
Vault Id: 1024CAA16E0CA7647AA046F6AFA807C2C1110000ev
For more information, see Help and Support Center at http://telemetry.community.veritas.com/entt?product=ev&language=english&version=12.0.0.0&build=12.0.0.1528&error=V-437-6605
The list of Retention Categories is too large for the data type used for its variable.
This issue only affects the following versions of Enterprise Vault:
11.0.1 CHF2 - CHF5
12.0.0 - 12.1.1
This issue has been addressed in the following release available from Downloads:
Enterprise Vault 12.1.2
Workaround for earlier releases:
Reducing the number of expirable Retention Categories will alleviate the problem. Check the box that says "Prevent automatic deletion of expired items with this category" on the Properties page of a Retention Category, and it will not be included when expiry generates this list. Disable enough Retention Categories in this fashion to bring the list down to beneath 8,000 characters, and the problem will be averted for the time being.
The following SQL statement can be run against the EnterpriseVaultDirectory database to get an idea of how far off you are from the character limit on the data type. Keep disabling expiry on Retention Categories until the last column returned by this query shows "True."
DECLARE @RCOutFull varchar(max)
DECLARE @RCOutTrunc varchar(8000)
DECLARE @SiteEntryId EVGUID = (SELECT SiteEntryId FROM Siteentry)
DECLARE @DirectorySchemaVersion varchar(19)
SELECT @DirectorySchemaVersion = SchemaVersion FROM DirectoryEntry
IF SUBSTRING(@DirectorySchemaVersion,1,2) = '11'
BEGIN
EXEC getexpirableretentioncategories @SiteEntryId, @RCOutFull OUT;
EXEC getexpirableretentioncategories @SiteEntryId, @RCOutTrunc OUT;
END
IF SUBSTRING(@DirectorySchemaVersion,1,2) = '12'
BEGIN
EXEC getexpirableretentioncategories @SiteEntryId, 0, @RCOutFull OUT
EXEC getexpirableretentioncategories @SiteEntryId, 0, @RCOutTrunc OUT
END
SELECT @RCOutFull AS FullResults
,LEN(@RCOutFull) AS FullResultsLength
,@RCOutTrunc AS TruncatedResults
,LEN(@RCOutTrunc) AS TruncatedResultsLength
,(CASE WHEN @RCOutFull = @RCOutTrunc THEN 'True' ELSE 'False' END) AS ListIsShortEnoughToUse
When Storage Expiry runs and more than approximately 125 Retention Categories are enabled for expiry (i.e., "Prevent automatic deletion of expired items with this category" is not selected on the Retention Category's properties), the Storage Expiry run will fail and the following errors will be logged in the Event Viewer:
ETrack: 3904980